ATTENTION la méthode présenté ici est totalement badass et peu complètement détruire votre système... Eh méthode du troll oblige :D

Non plus sérieusement, il y à peu de chance que ça arrive, mais ce que je veux dire par là c'est que j'utilise régulièrement cette technique et n'ai pas encore eu le moindre problème. Cela m'étonnerait que ça bousille votre installation. Juste c'est possible et je ne me porte garant pour rien.
Le plus simple étant tout simplement de faire une sauvegarde avant d'essayé cette technique.

Vous êtes sur Archlinux version arm et hop vous pensez profiter comme d'habitude de la multitude de logiciel à votre disposition, lancer un petit:

yaourt nomDuProgrammeAinstaller

Et hop l'installation échoue lamentablement par un ce programme n'est pas compatible avec l'architecture arm.
Et là vous vous dîtes mais merde on peu rien installer sur une architecture arm ou quoi.

Et bien si c'est juste que beaucoup de paquet aur sont compatible arm mais n'on pas était testé sur cette architecture, leur script d'installation ne comporte donc pas la mention compatible arm. Ce que je vous propose donc, c'est d'ajouté l'indication comme quoi le programme en question est compatible.

Pour ce faire, dans le terminal lorsque l'on vous propose d'éditer le pkgbuild, répondais oui, et dans la partie listant les architectures compatibles:

arch=('i686' 'x86_64')
ajouter celle demandé, par exemple pour un raspberry pi de modèle B :
arch=('i686' 'x86_64' 'armv6h')

Essayé de l'installer à nouveau et ensuite prier gaya pour que tout ce passe bien.
Alors ça peut paraître flippant dit ainsi, mais pour l'avoir fait plus d'une dizaine de fois, je peux vous dire qu'en générale ça fonctionne. Je dis ça parce-qu'il m'est arrivé une fois ou la compilation ne fonctionnait pas tout simplement. Là rien de grave , je n'ai pas installé mon logiciel et ai juste désinstallé les dépendances qui du coup n'était pas utilisé.